Investigating problems reported on Access Server Billing Portal and OpenVPN Cloud Subscription and Billing Management
Incident Report for OpenVPN
Resolved
Access Server Billing Portal and OpenVPN Cloud Subscription and Billing Management are back up and running. If you continue to experience any troubles, reach out to Support. Thank you for your patience.
Posted Aug 12, 2022 - 12:40 UTC
Identified
We received some complaints about customers being unable to download PDF invoices from AS-Portal and Cloud-Billing. Our internal team is working for this to be fixed today or early next week. For now, feel free to reach our support to get an invoice upon request. Thank you!
Posted Aug 12, 2022 - 11:52 UTC
This incident affected: Access Server Licensing (Access Server Billing Portal) and OpenVPN Cloud Subscription and Billing Management.