Problems reported on users of Access Server Subscriptions
Incident Report for OpenVPN
Postmortem

On September 29th 2022 we received several reports from customers using OpenVPN Access Server with a subscription license on the Microsoft Azure platform. The root cause was an unattended upgrade performed in the operating system Ubuntu 18.04 LTS approximately 30 days ago which caused a race condition that broke DNS resolution on Microsoft Azure. Other platforms were not affected.
The broken DNS resolution caused the Access Server to be unable to contact our subscription licensing system to refresh its licensed state for a prolonged period of time. While our systems were up and running and reachable, the affected systems on Azure were unable to resolve the domain name of our subscription server and were therefore unable to reach it. While our subscription licensing system has a great deal of flexibility in dealing with temporary connection problems, it does eventually lose its licensed state if contact cannot be established for a prolonged period, which was the case here.
The issue can be resolved by either rebooting the virtual instance or repairing the DNS settings in the operating system. The affected Access Server systems will then have a working DNS configuration again and can then refresh their licensed state automatically to restore normal operation.
Steps to prevent this issue from recurring on Microsoft Azure are being taken by Microsoft and Canonical and more information on this can be found in Azure's incident history report. The incident report from Microsoft that describes what caused the problem originally, dated August 30th 2022, can be found here: https://status.azure.com/en-us/status/history/

Posted Sep 29, 2022 - 21:33 UTC

Resolved
Access Server Subscription Licensing is back up and running. If you continue to experience any troubles, reach out to Support. Thank you for your patience.
Posted Sep 29, 2022 - 19:22 UTC
Identified
Currently users of Access Server Subscriptions may experience problems on Microsoft Azure. The root cause is an unattended upgrade of Ubuntu 18.04 LTS that could lead to a loss of DNS configuration due to a race-condition bug (https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1988119). A reboot of the affected instance should restore DNS settings and resolve the situation. Our support team is standing by to assist you in resolving this situation.
Posted Sep 29, 2022 - 11:53 UTC
This incident affected: Access Server Licensing (Access Server Subscription Licensing).