Investigating problems reported on Brussels and London CloudConnexa Region

Incident Report for OpenVPN

Resolved

Brussels and London CloudConnexa Region issues is resolved. If you continue to experience any troubles, reach out to Support. Thank you for your patience.
Posted Oct 09, 2025 - 15:36 UTC

Identified

The Brussels, Belgium, region is now operating normally. The issue in one of our data centers in the London region has already been identified, and work is underway to fix it.
Posted Oct 02, 2025 - 18:08 UTC

Update

We are continuing to investigate this issue.
Posted Oct 02, 2025 - 11:59 UTC

Investigating

We are investigating reports about issues in Brussels and London CloudConnexa Region
Posted Oct 02, 2025 - 11:11 UTC
This incident affected: CloudConnexa Regions (CloudConnexa - Region Brussels, Belgium, CloudConnexa - Region London, United Kingdom).