Investigating performance issue reported on CloudConnexa.

Incident Report for OpenVPN

Resolved

This incident has been resolved.
Posted Apr 26, 2025 - 14:22 UTC

Update

Load times improved for Eastern Europe users, investigation continues
Posted Apr 26, 2025 - 12:51 UTC

Update

Load times improved for Eastern Europe users, investigation continues
Posted Apr 26, 2025 - 12:50 UTC

Update

Some users from Eastern Europe may experience slower-than-normal load times due to an issue on the backbone provider’s side.
Posted Apr 26, 2025 - 12:04 UTC

Investigating

Some users may experience slower than normal load times.
Posted Apr 26, 2025 - 11:48 UTC
This incident affected: CloudConnexa SSO.