Degraded performance: Cyber Shield Domain Filtering
Incident Report for OpenVPN
Resolved
Cyber Shield Domain Filtering is back up and running. If you continue to experience any troubles, reach out to Support.

Thank you for your patience.
Posted Jun 27, 2022 - 12:52 UTC
Investigating
We are investigating complaints about detailed report generation for Cyber Shield Domain Filtering starting from 9:41 UTC.

Thank you for your patience.
Posted Jun 27, 2022 - 09:41 UTC
This incident affected: OpenVPN Cloud Portal (Cyber Shield Domain Filtering).